NoGripRacing.com

Go Back   NoGripRacing Forums > PC Racing > GTR2

Reply
 
Thread Tools
Old 28 February 09, 08:36   #1
ToMaCa
 
Join Date: Apr 2007
Default Stuttering although high FPS

Hi!
I sometimes experience stuttering although the frame rate signals 80-100fps. I havent been able to track that down. Any ideas? Its running on XP and yes, I have the grafics settings like maxed out, but most of the time it works smoothly. I reinstalled XP (and GTR2) not long ago so the installation is kinda fresh.
ToMaCa is offline   Reply With Quote
Old 28 February 09, 08:56   #2
redi
Superator
 
redi's Avatar
 
Join Date: Oct 2006
Location: On a thin crust covering a huge ball of hot molten stone whizzing through space
Age: 41
Default

If you have 80-100 FPS and in general 60+ FPS constantly, turn on VSync and enable Triple Buffering by using the information in this thread. This should get rid of any stuttering.
redi is offline   Reply With Quote
Old 28 February 09, 09:24   #3
ToMaCa
 
Join Date: Apr 2007
Default

Thanks, Ill try that.
ToMaCa is offline   Reply With Quote
Old 28 February 09, 10:08   #4
ToMaCa
 
Join Date: Apr 2007
Default

Well, I did a quick test, and Im not sure it did the trick.
It is some time since I played GTR2, just started again. Dont remember that I had this stuttering problem back then. Since then I have overclocked my CPU and memory and I clearly have better fps now. Ive also reinstalled XP (and GTR2).

A few questions:
1. I have my monitor update freq set to 85HZ. The tripple buffering setting would kick in when fps drops under that, right? Does it cost performance and if so, when does it cost?

2. In the ATI Catalyst Control Center I can set the triple buffering, but there also is a bar called "Wait for vertical refresh", going from performance to quality. How can syncronizing frame rate to the refresh rate be scalable?

2. Is there any graphic setting under Advanced that specificly is known to cause stuttering? (not just lowering the fps)
ToMaCa is offline   Reply With Quote
Old 7 March 09, 15:24   #5
Ytsejam
 
Join Date: Jun 2008
Location: Chicago
Default

I had the same problem, and solved it. It was my internet security. I use Kaspersky 2009. I updated to new version, and now is fine.
Ytsejam is offline   Reply With Quote
Old 7 March 09, 15:28   #6
LittleZippyUK
Resident Drifter
 
LittleZippyUK's Avatar
 
Join Date: Aug 2006
Location: Bournemouth, Dorset, United Kingdom
Age: 20
Default

X:\GTR2\ReplayData

I deleted my replays and it solved my stuttering. I had tons in there.

Try that.
LittleZippyUK is offline   Reply With Quote
Old 7 March 09, 17:53   #7
Visceral_Syn
Banned
 
Join Date: Mar 2007
Location: Memphis, TN
Age: 42
Default

Quote:
Originally Posted by ToMaCa View Post
1. I have my monitor update freq set to 85HZ. The tripple buffering setting would kick in when fps drops under that, right? Does it cost performance and if so, when does it cost?
Triple buffering doesn't 'kick-in', its an extra frame is drawn to a third buffer, in the case of the Double buffering, only 2 frames are drawn at a time. Anyway, if you have a video card with 256MB or more of video memory and are not using some insanely high resolution. Your video card should be able to draw the third frame, which does wonders in the the department of keeping framerates up.

It costs when Framerates drop under 60, because it goes down to 30fps.


Quote:
Originally Posted by ToMaCa View Post
2. Is there any graphic setting under Advanced that specificly is known to cause stuttering? (not just lowering the fps)
Yes, FSAA, Full Scene Anti-Aliasing. Most low resolutions render the wonderful jaggies so many people hate. However, once resolutions used start going up and over, say 1680*1050, jaggies start becoming less, and less, but people keep cranking up FSAA. And FSAA WILL murder framerates. On My 8800 GTS 512, i typically leave FSAA in the driver set to application, and in GTR config its set to 1 or 2, since the gMotor engine is fairly old, i change the QUALITY texture settings up to HIGH QUALITY, and set Anisotropic Filtering to max. Since the vid card isn't wasting away tryin to do FSAA, that leaves more oomph to crank up texture quality, with no loss of framerates. With Culmone67's textures, some screenshots are fabulous. I'm running that 8800 GTS 512 on a Samsung "22 2204BW, at 1680*1050@60hz, VSync enabled. Steady 60fps, it has dropped in the rain, and at night. But Rain or night alone, not together stays at 60fps.

...Syn...
Visceral_Syn is offline   Reply With Quote
Old 7 March 09, 23:40   #8
Freddyfartbox
 
Freddyfartbox's Avatar
 
Join Date: Oct 2006
Location: Bunbury. Western Australia.
Age: 35
Default

What other programs do you have running in the background? Ages ago I installed a temp monitoring tool which made rFactor stutter, so check what you have running.
Freddyfartbox is offline   Reply With Quote
Old 8 March 09, 17:33   #9
Petty Andretti
 
Petty Andretti's Avatar
 
Join Date: Jan 2007
Location: Macomb, Michigan
Default

Quote:
Originally Posted by Freddyfartbox View Post
What other programs do you have running in the background? Ages ago I installed a temp monitoring tool which made rFactor stutter, so check what you have running.
Which temp monitor were you using?
Petty Andretti is offline   Reply With Quote
Old 8 March 09, 21:58   #10
Freddyfartbox
 
Freddyfartbox's Avatar
 
Join Date: Oct 2006
Location: Bunbury. Western Australia.
Age: 35
Default

Quote:
Originally Posted by Petty Andretti View Post
Which temp monitor were you using?
Easy Tune 6. I tried a few other programs but they all seemed to give different readings, ET6 seemed the most accurate from what I could tell, but the stutters in rF were bloody annoying.
Freddyfartbox is offline   Reply With Quote
Old 10 March 09, 02:46   #11
montoyafan
 
Join Date: Oct 2006
Default

This may help. I was having bad stutters in GTR2 and rFactor and could not figure out why because it had just started and I had never had that problem before. Tried all sorts of stuff, new drivers, all kinds of setting in ATI tray tool, the works. Then I realized I had just changed my slave drive HDD and pasted everything back from my external, what I had neglected to do was turn off file indexing. Did that and, so far, stutters have gone away.

Worth a try. I also put AA back to level one to make sure I wasn't deluding my self and still ran smooth.

Hope this might help some of you.
montoyafan is offline   Reply With Quote
Old 10 March 09, 23:35   #12
robmypro
 
Join Date: Feb 2009
Default

This is a good discussion. I am getting a steady 60fps (my TV refresh is 60) but I also notice occasional stutters. I see that file indexing was on for the drive, so I am going to turn it off and give that a shot. I am also going to go through my services in Vista and see what I can turn off.
robmypro is offline   Reply With Quote
Old 11 March 09, 16:22   #13
ToMaCa
 
Join Date: Apr 2007
Default

The file indexing we are talking about here is the one I find when I select HD preferences, right?
ToMaCa is offline   Reply With Quote
Old 11 March 09, 17:20   #14
robmypro
 
Join Date: Feb 2009
Default

I went into My Computer, right clicked the C drive, and then went into properties. Then there is a checkbox there for indexing.
robmypro is offline   Reply With Quote
Old 11 March 09, 17:30   #15
Josepmaria
 
Josepmaria's Avatar
 
Join Date: May 2003
Location: La Font del Gat ;-)
Age: 61
Default

Quote:
Originally Posted by robmypro View Post
I went into My Computer, right clicked the C drive, and then went into properties. Then there is a checkbox there for indexing.
So you turned it off and ... what happened ?????

Josepmaria is offline   Reply With Quote
Old 11 March 09, 22:55   #16
robmypro99
 
Join Date: Mar 2009
Default

It seemed to work yesterday, but today they stuttering is back. Looking into it right now.
robmypro99 is offline   Reply With Quote
Old 11 March 09, 23:24   #17
scca1981
 
scca1981's Avatar
 
Join Date: Dec 2006
Age: 33
Default

That's not the proper way to turn off indexing.

For XP:
Control Panel/Admin Tools/Services/Indexing Service

To see if its on, go to start/search/"with indexing service" in the side search companion box

I'm not sure on vista but i'm going to assume is similar.
scca1981 is offline   Reply With Quote
Old 12 March 09, 00:45   #18
robmypro99
 
Join Date: Mar 2009
Default

Okay I will try that. Thanks.
robmypro99 is offline   Reply With Quote
Old 12 March 09, 01:05   #19
scca1981
 
scca1981's Avatar
 
Join Date: Dec 2006
Age: 33
Default

There is no guarantee it will stop game stuttering. Its quite possible its the video card drivers.

Keep your HD defragmented also.
scca1981 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 20:43.


Powered by vBulletin® - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

www.nogripracing.com 2003 - 2014
Page generated in 0.11481 seconds with 10 queries