NoGripRacing.com

Go Back   NoGripRacing Forums > PC Racing > GTR2 > Power and Glory Mod

Reply
Thread Tools
Unread 20 November 12, 05:46   #101
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

Quote:
Originally Posted by maseratialfa View Post
Offline P&G runs fine with the highest possible resolution. I am running triple 27s using eyefinity for the ATI cards. The menu will be streched, but the Sim itself will run fine. Online I have only been able to use 2400x600 resolution without CTD, and higher crashes. Be sure to run GTR2 config as admin when changing settings, and of course the exe as admin. It also helps to keep the Sim installed out of program files, or program files x86 in Windows 7. I guess softth has something to do with your screen sizing. You could try ATI Catalyist and set up through eyefinity for your triplescreen set up.
Just a personal request, as noone in the team is currently using triple-screens...

If one of of you guys with such setup can compose a detailed thread with tips and solutions for running P&G with triple-screens, online and offline, including with SoftH, etc, we would be gratefull and create a pinned-topic for those seeking help in that regard.


Quote:
Originally Posted by jks View Post
PnG3 worked well for about a week but now it started to cause a fault error in GTR2.exe related to the bink32.dll. I thought that bink32 had something to do with playing movie files. Anyone have a clue on this?
Please try this:

Go to the "...\[P&G install]\MovieFiles" folder, and delete all the 9 files in there.

Don't worry, it won't delete the main-menu background movie.
The reason for the possible bink32.dll error is because we left blank bink.videos to bypass the original GTR2 "modern" videos and intros, and sometimes it causes conflicts. Deleting them all as pointed above should solve it.

Last edited by DucFreak; 20 November 12 at 06:00.
DucFreak is offline   Reply With Quote
Unread 21 November 12, 04:42   #102
jks
 
Join Date: Aug 2006
Default

Thank you Duc. By the way, I have enjoyed your sound files from GPL onwards. Great engine sounds really make the immersion real.
jks is offline   Reply With Quote
Unread 27 November 12, 11:29   #103
Art-J
 
Art-J's Avatar
 
Join Date: Jul 2006
Location: Warsaw, Poland
Default

Jks, I think you might be confusing DucFreak with DucWolf (Ha, this never gets old ).

Anyway, back on topic - I just popped in again to say the "delete9filesfrommoviefolder" solution works for me. So far I copied all troublesome tracks back into my locations folder and P&G fires up just fine, even without debug mode. Glad to have this finally sorted!
Art-J is offline   Reply With Quote
Unread 27 November 12, 18:59   #104
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

Quote:
Originally Posted by Art-J View Post
Jks, I think you might be confusing DucFreak with DucWolf (Ha, this never gets old ).

Anyway, back on topic - I just popped in again to say the "delete9filesfrommoviefolder" solution works for me. So far I copied all troublesome tracks back into my locations folder and P&G fires up just fine, even without debug mode. Glad to have this finally sorted!
Yes, we're aware of the problem and, like said, it occurs randomly.
We're looking for a simple solution to delete the files, without user intervention, with the next coming patch.

And yeah, confusing me with DucWolf (maker of the best sounds ever for GPL, IMHO) is not something new, but it's all good.
DucFreak is offline   Reply With Quote
Unread 16 December 12, 17:22   #105
Pawgy
 
Pawgy's Avatar
 
Join Date: May 2003
Location: USA
Age: 82
Default Unable to installl v3

After getting a lot of help from Ducfreak and then using links from JJC1 finally able to download all 3 files plus the installer all separatly. I had a dedicated install of P&G 2 & 2.1 and Thank Goodness I made a copy and put it on my exteral drive in its entirety.

I unpacked the 3 .rar files and they are in a folder with the Installer.exe.

I went to my C drive dedicated install of P&G and uninstalled v2 and v2.1.

Then using the 2nd option I TRIED to install v3. Got right to the end ang gave me the "ERROR: unpacking error, status 2"...

ran the INtegrity check file and it says alll files are corrupt. THis after abour 4.5 hrs of downloadin and file 1 has 850meg file 2 has 850meg and file3 has 692 meg.
So basicly I give up.

luckily my external P&G still works.

The disgusting thing is after using the installer.ext my GTR2 no longer will run. now I have to try to figure out what is wrong with IT.

Pawgy
Pawgy is offline   Reply With Quote
Unread 16 December 12, 17:34   #106
freejrs
 
freejrs's Avatar
 
Join Date: Aug 2007
Location: The Shire
Age: 31
Default

Quote:
Originally Posted by Pawgy View Post
I went to my C drive dedicated install of P&G and uninstalled v2 and v2.1.

Then using the 2nd option I TRIED to install v3. Got right to the end ang gave me the "ERROR: unpacking error, status 2"...
Why didn't you just do a fresh install of GTR2 and then use that for the P&G V3 installation instead of trying to clean your old V2 install up???

Seems to me even if you uninstalled V2 and 2.1 you are still going to have files in there which will confuse the installer and/or cause a complete failure. Trying to save time by not doing a fresh install has just made it a longer process.

Do a fresh install of GTR2 from disc and start again using that as the base for your V3 install.

I could be wrong andmayybe there is just something corrupt in your download but start with the simplest thing first.......
freejrs is offline   Reply With Quote
Unread 16 December 12, 17:52   #107
AzRiM
 
AzRiM's Avatar
 
Join Date: Mar 2008
Location: Bosnia and Herzegovina, Tuzla
Age: 34
Default

Quote:
Originally Posted by Pawgy View Post
After getting a lot of help from Ducfreak and then using links from JJC1 finally able to download all 3 files plus the installer all separatly. I had a dedicated install of P&G 2 & 2.1 and Thank Goodness I made a copy and put it on my exteral drive in its entirety.

I unpacked the 3 .rar files and they are in a folder with the Installer.exe.

I went to my C drive dedicated install of P&G and uninstalled v2 and v2.1.

Then using the 2nd option I TRIED to install v3. Got right to the end ang gave me the "ERROR: unpacking error, status 2"...

ran the INtegrity check file and it says alll files are corrupt. THis after abour 4.5 hrs of downloadin and file 1 has 850meg file 2 has 850meg and file3 has 692 meg.
So basicly I give up.

luckily my external P&G still works.

The disgusting thing is after using the installer.ext my GTR2 no longer will run. now I have to try to figure out what is wrong with IT.

Pawgy
Reading this all now you must have made a wrong"step" along the way, please read this post HERE
AzRiM is offline   Reply With Quote
Unread 16 December 12, 18:05   #108
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

I'm very sorry to hear about your problems .

Now we have to solve few things. First I don't know where you got the 4 files and in what form, but most of the distributing servers offers files uncompressed and ready to use; you should get/have these: PnGv3.0_installer.exe, PnGv3.0.001, PnGv3.0.002, PnGv3.0.001.

When downloading them from a download page (in your web browser), you need to use "Save as.." functionality. If you are not familiar with this, then do this: put the cursor over the link/filename, use the right mouse button to open a popup menu and pick the "Save as" or similar from there and then a location to save them to. And this process for all the four files.

If you have the torrent version, then you will get a single PnGv3.rar which will give you the same 4 files when uncompressed.

In either way: do not try to uncompress the 001, 002 or 003 files by yourself.

I know it's a real bummer when option#2 can't finish because of failing packages. You could check if you have this folder in your trashed GTR2 installation: "somedir". If you have it, you can try to restore all those file back where they were (this is a temporary place where the deleted files are collected to before final compression). You go to that "somedir" folder, select ALL files and folders there, copy them to clipboard (with Ctrl-C for example) and then move back to your GTR2 folder and paste them all (Ctrl-V).
If asked about overwriting files, please let it do that.

I'm not sure how the above process would end (if it will help or not). If not, then you might try to do a fresh GTR2 installation, or two. This might be the easiest way to go. Recovering something trashed is always messy process with unknown ending.

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 16 December 12, 18:25   #109
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Quote:
Originally Posted by aSa View Post
...First I don't know where you got the 4 files and in what form, but most of the distributing servers offers files uncompressed and ready to use; you should get/have these: PnGv3.0_installer.exe, PnGv3.0.001, PnGv3.0.002, PnGv3.0.001.....
to clarify he got them from me via GC (wrapped in .rar 'cos GC web server is not set up to allow .001, .002, and .003 files yet)
PnGv3.0.001.rar
PnGv3.0.002.rar
PnGv3.0.003.rar

So @Pawgy... after unpacking you should end up with these 3 files ... all in the same folder as the installer...

PnGv3.0.001
PnGv3.0.002
PnGv3.0.003

right?

Last edited by JJC1; 16 December 12 at 22:46.
JJC1 is offline   Reply With Quote
Unread 16 December 12, 18:32   #110
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Quote:
Originally Posted by freejrs View Post
...Do a fresh install of GTR2 from disc and start again using that as the base for your V3 install....
This is essential advice imo.

And to avoid other probs don't let it install under the C:\Program Files folder !

make it install in for example C:\PnGV3
JJC1 is offline   Reply With Quote
Unread 17 December 12, 14:38   #111
drosofilamelanogast
 
Join Date: Jan 2007
Default

Hi all! Congratulations for the great mod/sim!

I've this strange problem:

- I installed GTR2 with dvd, updated software at 1.1 version (WE), in C:\Progam files\PnG GTR2;

- I made a stand alone installation of the PnG 3.0, in C:\Program files\PnG.

I can start the sim after the installation, play it and have fun, but if I quit the game, and I try to launch it again, there'is the microsoft icon telling me the software has finisched to function, and then it never start again! Only after another installation!

I can't understand where is the problem!

Do you have any suggestion?

Thanks a lot,
Giusto

Intel Core Duo E6750 2.66Ghz
2Gb Ram DDR2 800Mhz
Nvidia 250 Gts 1Gb
Corsair modulare 650W
Asus P5KC
HD Seagate Barracuda Sata
drosofilamelanogast is offline   Reply With Quote
Unread 17 December 12, 15:27   #112
Art-J
 
Art-J's Avatar
 
Join Date: Jul 2006
Location: Warsaw, Poland
Default

If you are using Win7 or 8, the first and most important suggestion is written just above your post - it's generally not a good idea to install any old game in Program Files folder, unless you want to deal with problems caused by Windows UAC.
Art-J is offline   Reply With Quote
Unread 17 December 12, 16:15   #113
drosofilamelanogast
 
Join Date: Jan 2007
Default

Quote:
Originally Posted by Art-J View Post
If you are using Win7 or 8, the first and most important suggestion is written just above your post - it's generally not a good idea to install any old game in Program Files folder, unless you want to deal with problems caused by Windows UAC.
Ok, thanks!
Before installing GTR2 and PnG in Program Files, I'va installed both in antoher patrition of my hd D:\Games (where I have all of my games), but there was this problem! So, I decided to try in C:\Program Files.

I'll try again in D:...I don't know what to do...

In D:\Games I have antoher installation of GTR2 with the nap mod...perhaps this can create conflict? (Strange because the GTR2 base is different)

Thanks!
drosofilamelanogast is offline   Reply With Quote
Unread 17 December 12, 16:26   #114
frapp
 
Join Date: Nov 2006
Default

I have a major problem with the P&G mod.


There are only 24 hours in a day!

No probs with install everything runs smooth as silk. This mod rocks!


Thank you for a great work.


FraPP!!!
frapp is offline   Reply With Quote
Unread 17 December 12, 18:21   #115
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Quote:
Originally Posted by drosofilamelanogast View Post
...I'va installed both in antoher patrition of my hd D:\Games (where I have all of my games), but there was this problem! So, I decided to try in C:\Program Files.

I'll try again in D:...I don't know what to do...
try again in C:\PnGV3 for example,
(you said D: gave you a problem?)


Quote:
Originally Posted by drosofilamelanogast View Post
In D:\Games I have antoher installation of GTR2 with the nap mod...perhaps this can create conflict?...
No
JJC1 is offline   Reply With Quote
Unread 17 December 12, 18:26   #116
drosofilamelanogast
 
Join Date: Jan 2007
Default

Quote:
Originally Posted by JJC1 View Post
try again in C:\PnGV3 for example,
(you said D: gave you a problem?)




No
Ok, I'll try, thanks again!
drosofilamelanogast is offline   Reply With Quote
Unread 17 December 12, 19:13   #117
Pawgy
 
Pawgy's Avatar
 
Join Date: May 2003
Location: USA
Age: 82
Default My Apologies please.

I guess i should try to explain how badly I did on my attempt to install v3.

I should have listened and started with a new gtr2 instal instead of trying to uninstall v2. and 2.1

When I downloaded the 4 files from a very gracious JJc1 I inadvertantly saved each one in a folder and of-course they would not run when each was in a separate folder.

As soon as i followed the instructions carefully I was abe to install v3. My mistake then was to install it over my very big original install of gtr2.

None of my original gtr2 cars would now run. It is not a major problem as my original gtr2 was getting very large and unmanagable anyways.

I have now gone back and with v3 and all its cars running successfully and removed all the original car files that will not run .In effect I ended up with a dedicated P&G v3 game.

Now I will go back and reuinstall GTR2 without all the garbage I had accumulated.

I would like to thank Ducfreak for his very generous help. Also JJC1 .I am very sorry for all the trouble i may have caused. I just do not do things as well at 77 as when I was younger. P&G v3 is a wonderful addition to GTR2 . and GTR2 is still a great game.

Holiday wishes and reguards to all who tried to help.
Pawgy

And a very big thankyou to the makers and updaters of P&Gv3.

Last edited by Pawgy; 17 December 12 at 19:25.
Pawgy is offline   Reply With Quote
Unread 18 December 12, 12:48   #118
freejrs
 
freejrs's Avatar
 
Join Date: Aug 2007
Location: The Shire
Age: 31
Default

Quote:
Originally Posted by Pawgy View Post
In effect I ended up with a dedicated P&G v3 game.
That is what you wanted to do from the start.

P&G requires a standalone installation as stated in the instructions.
freejrs is offline   Reply With Quote
Unread 18 December 12, 13:02   #119
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

Quote:
Originally Posted by Pawgy View Post
(...)
In effect I ended up with a dedicated P&G v3 game.
(...)
I would like to thank Ducfreak for his very generous help. Also JJC1 .I am very sorry for all the trouble i may have caused. I just do not do things as well at 77 as when I was younger. P&G v3 is a wonderful addition to GTR2 . and GTR2 is still a great game.

Holiday wishes and reguards to all who tried to help.
Pawgy

And a very big thankyou to the makers and updaters of P&Gv3.
You're welcome! Glad you got it sorted.
We hope you're enjoying all the new content in v3, as well as the 'upgrade' from v2.1 as well.
DucFreak is offline   Reply With Quote
Unread 18 December 12, 14:45   #120
drosofilamelanogast
 
Join Date: Jan 2007
Default

Hi all!

I installed GTR2 and PnGv3 in C:, but the error is still there!

It's always the same in C:, C:\Program Files, D:\Games, so there is only the format

Last suggestions?

Thanks
drosofilamelanogast is offline   Reply With Quote
Unread 19 December 12, 07:23   #121
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

drosofilamelanogast:
Are you starting PnG with the Launcher tool? If you're, try (with a fresh PnG) starting directly the GTR2.EXE file you find from the PnG folder.

If this solves the weird "corruption" problem (or what ever that might be), I have an updated Launcher already build that might have a solution for it.

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 19 December 12, 13:07   #122
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Quote:
Originally Posted by drosofilamelanogast View Post
...
I can start the sim after the installation, play it and have fun, but if I quit the game, and I try to launch it again, there'is the microsoft icon telling me the software has finisched to function, and then it never start again!...
Does it give any error when it refuses to start?

Do you have a prog called D3DOverrider running? (If yes then kill it. )
JJC1 is offline   Reply With Quote
Unread 14 January 13, 08:55   #123
mickyedna
 
mickyedna's Avatar
 
Join Date: Oct 2007
Location: The garden of England
Age: 57
Default

My problem is that if I point logitech profiler (with specific game settings like wheel rotation) to P n G launcher, my specific game settings are ignored and it uses global settings. If I point profiler to gtr2 exe the specific game settings are used.
mickyedna is offline   Reply With Quote
Unread 14 January 13, 13:09   #124
Mad Hamish
 
Mad Hamish's Avatar
 
Join Date: Jan 2007
Location: Jylland
Age: 54
Default

i think you should point the profiler to the gtr2.exe in your P&G folder.
Mad Hamish is offline   Reply With Quote
Unread 14 January 13, 15:50   #125
jandri
Uploader
 
jandri's Avatar
 
Join Date: Aug 2010
Default

Quote:
Originally Posted by mickyedna View Post
My problem is that if I point logitech profiler (with specific game settings like wheel rotation) to P n G launcher, my specific game settings are ignored and it uses global settings. If I point profiler to gtr2 exe the specific game settings are used.
Same here but you can use the PnG launcher once and does what is needed. Then start the game with the GTR2 exe or shortcut. Executing the exe the wheels settings are there.
jandri is offline   Reply With Quote
Unread 26 January 13, 21:16   #126
kingtin
 
Join Date: Oct 2012
Default Deleting Moviefiles works

Thank you! Thank you!

Briliiant piece of engineering this mod (well, sim).

Deleting moviefiles (post#2) worked for me. Had PnG3 installed and working for a few days, then would ctd (crash to desktop) at startup. Deleted files, and now its running again.

Cheers

Tony
kingtin is offline   Reply With Quote
Unread 1 February 13, 01:21   #127
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

After adding new tracks for the WSL, the game won't start. The Silverstone track file didn't look right so I removed it. Started the game in debug mode and got this trace. I removed a few hundred of the "Could not find" lines.



TRACE LEVEL = 1000
netcomm.cpp 7902: NetComm checking command line: "-trace=1000"
game.cpp 633: Entered Game::Enter()
osman.cpp 469: Entered OSMan::Enter()
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
vidman.cpp 1011: Entered VidMan::Enter()
specialfx.cp 3577: Entered SpecialFX::Enter()
dynman.cpp 597: Entered DynMan::Enter()
plrfile.cpp 3783: Entered PlayerFile::Enter()
sound.cpp 700: Entered Sound::Enter()
hwinput.cpp 6527: Entered HWInput::Enter()
onscreen.cpp 3155: Entered OnScreen::Enter()
game.cpp 726: Entered Game::Setup()
hwinput.cpp 6541: Entered HWInput::Setup()
options.cpp 1657: Entered Options::Setup()
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
plrfile.cpp 2936: Attempting to save to USERDATA\robiker\robiker.TMP
plrfile.cpp 2959: Retcode: 0 for renaming to USERDATA\robiker\robiker.PLR
game.cpp 1181: Entered Game::Exit()
sound.cpp 831: Entered Sound::Exit()
specialfx.cp 4367: Entered SpecialFX::Exit()
hwinput.cpp 6649: Entered HWInput::Exit()
dynman.cpp 1509: Entered DynMan::Exit()
onscreen.cpp 3280: Entered OnScreen::Exit()
vidman.cpp 1801: Entered VidMan::Exit()
osman.cpp 505: Entered OSMan::Exit()
robiker is offline   Reply With Quote
Unread 1 February 13, 07:24   #128
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

Your game seems to "fail" after reading your .PLR file (starts exiting the exiting the game).

For starters, here's a clip from my help stash that might be helpful:
_______________________________

RESET CAR&TRACK

Sometimes an invalid car or track definition may stop you from starting PnG/GTR2 correctly. Then you need to do this (this is not harmfull procedure if done properly):

XP: Open your profile from "[PNG]\UserData\[profilename]\[profilename].PLR", where [PNG] means your PnG installation folder, like "C:\Program Files\PnG3". [profilename] is your profilename.

Vista or newer: Open your profile from "[PNG]\UserData\[profilename]\[profilename].PLR", where [PNG] means your PnG installation folder, like "C:\Program Files\PnG3". [profilename] is your profilename.

Edit only these lines listed below to empty ones (as they are in my example), leave the rest of the lines intact!

Quote:
[ TRACK ]
Track File=""
Track Description=""
AI Database File=""

[ DRIVER ]
Profile Vehicle File=""
Vehicle File=""
Reserved Vehicle File=""
Driver Name=""
Nationality=""
Starting Driver="0"
AI Controls Driver #2="1"
_______________________________

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 1 February 13, 13:28   #129
David Wright
 
David Wright's Avatar
 
Join Date: Jun 2006
Location: UK
Default

If that does't fix it, I recently had the problem of the game not starting after adding an add-on track and deleting the 0kb video files did the trick.
David Wright is offline   Reply With Quote
Unread 1 February 13, 15:19   #130
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

Quote:
Originally Posted by David Wright View Post
deleting the 0kb video files did the trick.

I didn't try that before because I couldn't see how it could be related, but that fixed it. Thanks.
robiker is offline   Reply With Quote
Unread 4 February 13, 20:58   #131
kingtin
 
Join Date: Oct 2012
Default

Hello all.

Please help. I'm trying to get the pitstop page in Vitumo XD to go away in Power and Glory 3 mod. There is this option in the ini file to set a keystroke that turns it on and off and it works for me in GTR2 itself, but not with the mod. Is this a bug?

I have posted in the GTR2 XD bug thread too.

Thanks

Tony
kingtin is offline   Reply With Quote
Unread 4 February 13, 22:09   #132
David Wright
 
David Wright's Avatar
 
Join Date: Jun 2006
Location: UK
Default

Quote:
Originally Posted by kingtin View Post
Hello all.

Please help. I'm trying to get the pitstop page in Vitumo XD to go away in Power and Glory 3 mod. There is this option in the ini file to set a keystroke that turns it on and off and it works for me in GTR2 itself, but not with the mod. Is this a bug?

I have posted in the GTR2 XD bug thread too.

Thanks

Tony
Looking at the XD homepage, the program is probably expecting six tyre compound options, as this is the case with the standard GTR2 cars. P&G cars do not all have six compound options. I'm wondering if this is the cause of the problem.
David Wright is offline   Reply With Quote
Unread 6 February 13, 01:49   #133
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

I created a second profile in the game, but I get a CTD when I try to practice or time trial using that profile.
robiker is offline   Reply With Quote
Unread 6 February 13, 04:57   #134
kingtin
 
Join Date: Oct 2012
Default

Quote:
Originally Posted by David Wright View Post
Looking at the XD homepage, the program is probably expecting six tyre compound options, as this is the case with the standard GTR2 cars. P&G cars do not all have six compound options. I'm wondering if this is the cause of the problem.
Thank you David for your quick reply.

After some quick testing, I couldn't get the pitstop key function to work in gtr2 either! It seems to be stuck off. Changed the button in the.ini file and it would not go off again. May be add-on cars with fewer tyre choices too. I'll live with it - not too important I suppose. Nice in short races though when there are no pitstops.

Thanks again.

Tony
kingtin is offline   Reply With Quote
Unread 6 February 13, 07:18   #135
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

kingtin:
Just a note if you're using Win7/8 and your game is installed at "C:\Program Files" or "C:\Program Files (x86)". In this case you should check that if you have a "copy" of your XD.INI in your VirtualStore folder (examples: "%LOCALAPPDATA%\VirtualStore\Program Files\PnG3" or "%LOCALAPPDATA%\VirtualStore\Program Files (x86)\PnG3") you should be editing THAT file, not the one in the normal PnG3 folder.

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 6 February 13, 07:24   #136
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

robiker:
Haven't had any problems with new profiles (yet) .. Anything interesting in trace log ?

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 6 February 13, 11:57   #137
kingtin
 
Join Date: Oct 2012
Default

Quote:
Originally Posted by aSa View Post
kingtin:
Just a note if you're using Win7/8 and your game is installed at "C:\Program Files" or "C:\Program Files (x86)". In this case you should check that if you have a "copy" of your XD.INI in your VirtualStore folder (examples: "%LOCALAPPDATA%\VirtualStore\Program Files\PnG3" or "%LOCALAPPDATA%\VirtualStore\Program Files (x86)\PnG3") you should be editing THAT file, not the one in the normal PnG3 folder.

cheers.. aSa C[_]
Hi aSa, thanks for the note. I am running XP SP3 with gtr2 and PnG3 on e drive.

Cheers

Tony
kingtin is offline   Reply With Quote
Unread 6 February 13, 12:11   #138
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

Quote:
Originally Posted by aSa View Post
robiker:
Haven't had any problems with new profiles (yet) .. Anything interesting in trace log ?

cheers.. aSa C[_]
Here's the end of the trace:


setup.cpp 1194: Could not find .HDC
vidman.cpp 1011: Entered VidMan::Enter()
specialfx.cp 3577: Entered SpecialFX::Enter()
dynman.cpp 597: Entered DynMan::Enter()
plrfile.cpp 3783: Entered PlayerFile::Enter()
sound.cpp 700: Entered Sound::Enter()
hwinput.cpp 6527: Entered HWInput::Enter()
onscreen.cpp 3155: Entered OnScreen::Enter()
game.cpp 726: Entered Game::Setup()
hwinput.cpp 6541: Entered HWInput::Setup()
options.cpp 1657: Entered Options::Setup()
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
tire_manager 1171: Non-existent tire brand ""
plrfile.cpp 2936: Attempting to save to USERDATA\robiker\robiker.TMP
plrfile.cpp 2959: Retcode: 0 for renaming to USERDATA\robiker\robiker.
robiker is offline   Reply With Quote
Unread 6 February 13, 17:34   #139
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Looks like a missing/misplaced .tyr file?

In which case the rest of the trace might contain a clue
JJC1 is offline   Reply With Quote
Unread 6 February 13, 18:38   #140
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

Here's the beginning of the trace. Everything in between is "Could not find .HDC".


TRACE LEVEL = 1000
netcomm.cpp 7902: NetComm checking command line: "-trace=1000"
game.cpp 633: Entered Game::Enter()
osman.cpp 469: Entered OSMan::Enter()
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
robiker is offline   Reply With Quote
Unread 6 February 13, 18:50   #141
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Quote:
Originally Posted by robiker View Post
Here's the beginning of the trace. Everything in between is "Could not find .HDC".


TRACE LEVEL = 1000
netcomm.cpp 7902: NetComm checking command line: "-trace=1000"
game.cpp 633: Entered Game::Enter()
osman.cpp 469: Entered OSMan::Enter()
setup.cpp 1194: Could not find .HDC
setup.cpp 1194: Could not find .HDC
Ok I get the same messages in my traces
no clues there then I think
JJC1 is offline   Reply With Quote
Unread 7 February 13, 02:33   #142
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

Got it working now.
The first time, I didn't have the wheel plugged in so I skipped the settings screen. That caused it not to create a settings folder in the userdata file.
robiker is offline   Reply With Quote
Unread 7 February 13, 07:30   #143
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

LOL! That's a new one : D Actually it sounded like a missing LOG folder, but then I remembered you had already dumped the trace log, so it couldn't be that.. So missing Settings folder also creates similar effect. Good catch!

cheers.. aSa C[_]
aSa is offline   Reply With Quote
Unread 7 February 13, 17:05   #144
robiker
 
robiker's Avatar
 
Join Date: Dec 2012
Location: Oklahoma
Age: 57
Default

Can't believe I figured that out on my own. When it comes to computers, I usually just make things worse.
robiker is offline   Reply With Quote
Unread 7 February 13, 18:01   #145
JJC1
 
JJC1's Avatar
 
Join Date: Apr 2008
Default

Well done
I can't believe we're still finding new SimBin bugs
JJC1 is offline   Reply With Quote
Unread 10 February 13, 16:53   #146
freejrs
 
freejrs's Avatar
 
Join Date: Aug 2007
Location: The Shire
Age: 31
Default

I currently have P&G installed on my SSD and would like to move it to my HDD.

Can I just move the whole folder from C: to E: or is it best I just do a reinstall from scratch?
freejrs is offline   Reply With Quote
Unread 10 February 13, 19:30   #147
animal ed
 
animal ed's Avatar
 
Join Date: Jan 2008
Default

Quote:
Originally Posted by freejrs View Post
I currently have P&G installed on my SSD and would like to move it to my HDD.

Can I just move the whole folder from C: to E: or is it best I just do a reinstall from scratch?
When I made my second install for testing it worked fine by copying to another partition so I think that you shouldn`t have a problem with that.


OK, now our problem: nobody can join the server (booted) no matter which track it is. Even with original ones and it`s fresh install - no online races yet. Server was reinstalled because of replay problems (small corrupted files) otherwise it was fine.

What could go wrong with fresh install?
Where to look, which group of stones to turn over ...
animal ed is offline   Reply With Quote
Unread 10 February 13, 19:55   #148
freejrs
 
freejrs's Avatar
 
Join Date: Aug 2007
Location: The Shire
Age: 31
Default

Thanks Ed, will try it now..
freejrs is offline   Reply With Quote
Unread 11 February 13, 07:30   #149
aSa
One of The P&G guys
 
aSa's Avatar
 
Join Date: Oct 2006
Age: 54
Default

animal ed:
If nobody is able to log in.. I would suspect something wrong with the server files.

Is this server from Steam files or "normal" files ? I have noticed that Steam-based server has some extra annoying "features" to look after (especially if you're trying to minimize those server files.. lol I haven't finished this yet). Note: the minimizing server creation script I have attached does NOT handle Steam-GTR2 files correctly.

If you are desperate and try the attached script, please modify the SOURCE and SERVER paths to your needs. There are some REM'd examples for you too.

You could also try using trace logging parameter with your server ! It doesn't usually give much clues but sometimes it helps.

And double check that your server uses the PnGv3 version of "specialfx.tec". This file is very special for PnGv3. It even differs from PnGv2! This would certainly get every body booted instantly.


cheers.. aSa C[_]
Attached Files
File Type: zip MakeNewServer_v12.zip (2.0 KB, 5 views)
aSa is offline   Reply With Quote
Unread 11 February 13, 18:17   #150
animal ed
 
animal ed's Avatar
 
Join Date: Jan 2008
Default

Thanks Ari.

Problem was "specialfx.tec" but still don`t know why because new install was done exactly like old one which was working fine.

Anyway, problem solved.
animal ed is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 14:50.
Home - Top

Powered by vBulletin® - Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

www.nogripracing.com 2003 - 2017
Page generated in 0.12810 seconds with 10 queries