NoGripRacing.com

Go Back   NoGripRacing Forums > PC Racing > GTR2

Reply
Thread Tools
Unread 5 October 14, 15:43   #101
jandri
Uploader
 
jandri's Avatar
 
Join Date: Aug 2010
Default

Hope you allow another student to write his opinion.
Based on experiments long ago, i understood it this way:
playerEngineVolumeMinimum=0 --> All engine sounds volume at 0 rpm
playerEngineVolumeThrottleFraction=0 --> ON-throttle volume 0 rpm
playerEngineVolumeRevFraction=0 --> All engine sounds volume at max rpm.
I put the last above 1 sometimes, trying to have the "1" earler than max. Does it work, not sure.


I made a video
https://www.youtube.com/watch?v=yi9TA1Op6_U

From my side, i simply try to make all sound loud just because they get in a game that has loud sounds either because of the game or because of other mods having them loud.
If i had control of the whole game or a big mod , i would for sure make them more peaky in terms of volume.
jandri is offline   Reply With Quote
Unread 6 October 14, 15:06   #102
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

Quote:
Originally Posted by jandri View Post
Hope you allow another student to write his opinion.
Based on experiments long ago, i understood it this way:
playerEngineVolumeMinimum=0 --> All engine sounds volume at 0 rpm
playerEngineVolumeThrottleFraction=0 --> ON-throttle volume 0 rpm
playerEngineVolumeRevFraction=0 --> All engine sounds volume at max rpm.
I put the last above 1 sometimes, trying to have the "1" earler than max. Does it work, not sure.


I made a video
https://www.youtube.com/watch?v=yi9TA1Op6_U

From my side, i simply try to make all sound loud just because they get in a game that has loud sounds either because of the game or because of other mods having them loud.
If i had control of the whole game or a big mod , i would for sure make them more peaky in terms of volume.
That's definitely not how it works as far as I'm concerned. But if it seems to work better for you, that is just fine. That's what is important for each of us afterall.

I've been around this stuff since about 2002, already have lost count on (unreleased) soundpacks and experiments long ago and, TBH, I feel I went better and happier going on my own doing practical stuff, instead of just getting drowned on theory. So at some point I ignored part of the known documentation from ISI to do that (which some would say is a "no-no" attitude).
Sometimes that's the better way, I think.

Like I said in previous post, the parameter settings are somewhat interconnected.
If you use a really high volume within the samples which, like you said, tend to be necessarily so to match the "vanilla" SFX (as well as other engine sounds), and then raise the 'playerEngineVolumeMinimum=' parameter to something like 7 or 8, you'll probably get a different picture from similar experiment.
DucFreak is offline   Reply With Quote
Unread 6 October 14, 15:53   #103
jandri
Uploader
 
jandri's Avatar
 
Join Date: Aug 2010
Default

You mean like distorsion and wisteling when overlaping?
Had been trying the attenuation numbers long ago and got some weird stuff with distorsion, too loud.
For me what i described seems to work and in the video sounds to me the way i described it.
I allways compress the lower samples less than the higher ones, sort of like going up a lader.
Not imposible for me to be wrong of corse. But like you said what it suits and works for each one.
jandri is offline   Reply With Quote
Unread 6 October 14, 16:08   #104
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

No, I mean the volume reactions across the rev-range (so, to RPM relation) as well as in relation to throtle inputs.
The distortion and 'whistling' issues are another different can of worms, much more related to the audio handling and processing of samples. The sample rate and quality of source (which pitch-bend can aggravate), as well as bad usage (or none usage) of Limiter/Maximizer, so on.
DucFreak is offline   Reply With Quote
Unread 6 October 14, 16:46   #105
jandri
Uploader
 
jandri's Avatar
 
Join Date: Aug 2010
Default

I just tried a GTL car with "0.9" as minimum volume and the difference i found is the less "contrast" between on/off-throttle. That for me is because the minimum volume controls all samples and is higher than the "playerEngineVolumeThrottleFraction" which i say that is for on-throttle but this time minimum volume wins.
Anyways,we are still in what suits better to each one.
jandri is offline   Reply With Quote
Unread 6 October 14, 16:52   #106
jandri
Uploader
 
jandri's Avatar
 
Join Date: Aug 2010
Default

Just saw this one and reminded me of here.

https://fbcdn-sphotos-b-a.akamaihd.n...ba719abae0786e
jandri is offline   Reply With Quote
Unread 6 October 14, 19:02   #107
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

Quote:
Originally Posted by jandri View Post
Just saw this one and reminded me of here.

https://fbcdn-sphotos-b-a.akamaihd.n...ba719abae0786e
HEHE Good one!
DucFreak is offline   Reply With Quote
Unread 13 March 15, 20:00   #108
fobos
 
fobos's Avatar
 
Join Date: Mar 2015
Location: POLAND
Default

hi
On view behind I put sound from cockpit. My next idea is put chain saw sound on BMW 840i .]

Last edited by fobos; 13 April 15 at 21:38.
fobos is offline   Reply With Quote
Unread 13 November 15, 17:34   #109
Bellof1234
 
Bellof1234's Avatar
 
Join Date: Sep 2015
Location: Germany
Default

I am really annoyed by the sounds of tire scrub and skid. Seems they can only be adjusted to 100% min. But is there a way to edit that in the files!? I really want to turn that sound way down cos it just sucks TBH.
Bellof1234 is offline   Reply With Quote
Unread 13 November 15, 19:29   #110
ical_everon
 
ical_everon's Avatar
 
Join Date: Jan 2013
Default

Quote:
Originally Posted by Bellof1234 View Post
I am really annoyed by the sounds of tire scrub and skid. Seems they can only be adjusted to 100% min. But is there a way to edit that in the files!? I really want to turn that sound way down cos it just sucks TBH.
I don't know (if possible) how to adjust them in *.aud file, but you can edit *.wav files.

Free sound editor: Audacity
Sound file: X:>YourGTR2folder\GameData\Sounds\, road_scrub_*.wav and road_skid_*.wav

...or (untested), edit your *.plr file:
Vehicle Scrubbing VolMult=""
Vehicle Scrubbing FreqGrip=""
Vehicle Scrubbing FreqSpeed=""
Vehicle Skidding VolMult=""
Vehicle Skidding FreqGrip=""
Vehicle Skidding FreqSpeed=""
ical_everon is offline   Reply With Quote
Unread 13 November 15, 19:57   #111
jgf
 
jgf's Avatar
 
Join Date: Nov 2005
Location: Columbus, OH
Age: 64
Default

Unlike rfactor, where you can adjust volume in the sfx files, GTR2 only has limited adjustment via the menus. The only option is adjusting the volume of the wav files in an audio editor (-6dB will cut the level in half, though you will probably do some trial-and-error as final levels will depend on your system and your ears).
jgf is offline   Reply With Quote
Unread 19 November 15, 08:18   #112
Maroon Cats 21
 
Join Date: Oct 2015
Default

I recently installed the "new sounds real crash v1_000 by drako90" and when I got into the game 2 cars in particular don't have sound when I'm facing forward anymore.

The are the Golf IV R32 and Panoz cars, both from mods I've downloaded. While I'm waiting to purchase another wheel, I'm using a logitech controller and I have the directional pad set to "look left & look right". These cars worked fine when initially installed.

While driving, the cabin is almost totally quite,,, I can barely hear the engine, but when I look to the left or right,, the engine sounds are 100% normal. So, I figure the sounds are working but something has changed that only mutes the forward facing view's sound. I deleted all those "new sounds files" and replace the folder with my 'back-up' sounds folder that I kept but nothings changed. Any thoughts or directions? Thanks

Last edited by Maroon Cats 21; 22 November 15 at 16:06. Reason: clarity
Maroon Cats 21 is offline   Reply With Quote
Unread 22 November 15, 17:52   #113
Maroon Cats 21
 
Join Date: Oct 2015
Default

I re-installed a back-up and thought it resolved my issues. The game ran for about 2 days with the Panoz and R32 "forward facing" sounds working again just fine.

Last night I started adding more tracks and was testing each one individually but I started using other cars to test drive the tracks. After installing Monaco, Laguna Seca, LeMans 24hr and Tsukuba,,, somewhere during that time,,, the forward driving engine sounds are now gone again for only those 2 cars.

While driving and looking left or right,,, I have full engine sound and volume,,, but not wile facing out of the front window. All of the cars installed with the original game work fine. I installed the DTM mod and those sounds are fine as well. There seems to be something about the Panoz and Golf R32 installs that get affected by other installs,,,,

This thread has some great info but I don't seem to have a sound problem other than these 2 cars and only while facing forward.

"http://www.nogripracing.com/forum/showthread.php?t=349511&highlight=sound&page=2"
Maroon Cats 21 is offline   Reply With Quote
Unread 12 March 16, 13:12   #114
Spitfire7
 
Join Date: Nov 2011
Default

Hey guys great stuff you're doing here. I read through the entire thread trying to find the answer to my question and still I am confused. I am new to audio editing, but my question is a simple one. I downloaded a new mod with a large pack of cars and they are all set to a very quiet volume. These are full GTLM Ferrari, Porsche, etc. and they are all very subtle. So I just want to increase the overall exterior volume including the drive by volume. I edited the ATTENUATION and the ENGINE VOLUME MIX. Doing so did little to nothing. Actually I didn't even notice a difference. I was mostly tinkering with the playerEngineVolumeMinimum which started at 0.4 and I went all the way up to 1.8 to 4.0 to even 20 and there was little to no difference when doing an outside view. I checked this with several different cars in the mod pack and all did little to nothing. What am I doing wrong here?

Here are my setting which are extremely quiet.

EngineRange=100.0
EngineShape=0.90
EngineAmbient=5.00

ShiftRange=100.0
ShiftShape=1.00
ShiftAmbient=1.00

OtherRange=90.0
OtherShape=1.00
OtherAmbient=1.00


// ENGINE VOLUME MIX

playerEngineVolumeMinimum=1.0
playerEngineVolumeThrottleFraction=0.5
playerEngineVolumeRevFraction=0.25

non-playerEngineVolumeMinimum=0.9
non-playerEngineVolumeThrottleFraction=0.5
non-playerEngineVolumeRevFraction=0.254
Spitfire7 is offline   Reply With Quote
Unread 12 March 16, 17:16   #115
DucFreak
 
DucFreak's Avatar
 
Join Date: Mar 2006
Location: Lisboa, Portugal
Age: 42
Default

@Spitfire7:

The values you are using there are already higher than optimal (and above limits), IMHO.
It will cause other unwanted issues.

By your description and impressions, with such radical values not making any perceptible changes of relevance, then it just seems that the external sound samples in the mods that you are using are simply too silent, too low on volume.
What I mean is, it doesn't seem to be the kind of volume problem that can be 'fixed' by increasing the values for volume parameters in the .AUD files.

Since the problem seems to only occur with the external sounds, I would suggest to adjust/increase the dB values (volume) directly in the respective sound samples, with a sound editor software.
DucFreak is offline   Reply With Quote
Unread 27 June 16, 17:53   #116
XtC24
 
Join Date: Jun 2015
Default

Hi,

I have a problem with the Toyota 040 Hybrid "stock" sound from LM HY 2014 pack.

I have problem - when the 6/7th (the last especially) gear is on, the sound is like there would be further gear changes, the revs are going up, and then down and up again.

I mean there is the right sound and there is also other one which keeps "changing gears".

I have replaced the aud file with another one but I like the "stock" better, it is quite realistic.
tried to fix it but nothing helped. Any ideas ?

Thanks.
XtC24 is offline   Reply With Quote
Unread 27 June 16, 23:15   #117
GTR2man
Premium Member
 
Join Date: Nov 2006
Location: Dayton, OH, USA
Age: 77
Default

Can you explain why the sound volume of a car on a long straight with little or no RPM change would decrease and start over again after a very shot pause? The volume drop seems cyclic so might be connected to the length of the sound file. And how to fix it?
Thanks
GTR2man is offline   Reply With Quote
Unread 27 June 16, 23:59   #118
jgf
 
jgf's Avatar
 
Join Date: Nov 2005
Location: Columbus, OH
Age: 64
Default

Quote:
Originally Posted by GTR2man View Post
Can you explain why the sound volume of a car on a long straight with little or no RPM change would decrease and start over again after a very shot pause? The volume drop seems cyclic so might be connected to the length of the sound file. And how to fix it?
Thanks
Depending on the sim this can happen when the .aud/.sfx/.ini/.cfg parameters are not correctly set for the .wav file(s) in use (improper overlap of two files). Also a common occurrence when using sounds from one car with another similar, but not identical, car (for example, the car revs to 10k but the sounds are for an engine that revs to 9k; the sound will stop playing at 9k even though the engine continues revving).

Another consideration is a poorly edited .wav file - volume or timbre fluctuations, even dead spots (if memory serves me well there was an issue with the latter in the early days of GTL, when the sound files were first decrypted). This is often the issue with sounds cut from videos and not fully tested; they may sound fine on tracks with no long straights, where the engine never runs near redline very long, but take them to the Mulsanne and notice a pulsing, "washing machine", effect.

If you are still using XP, changing the sound acceleration may clear up such problems (hardware acceleration was dropped after XP).
jgf is offline   Reply With Quote
Unread 5 July 16, 02:27   #119
GTR2man
Premium Member
 
Join Date: Nov 2006
Location: Dayton, OH, USA
Age: 77
Default

jgf,
Thanks for your reply. I haven’t encountered the problem for a few weeks and have been going back looking for the car(s) which had the problem. Haven’t found any yet but will keep looking.

I’ve been converting old (50’s-60’s) cars from GTL to PnG (for my own use) and running them on JCRR’s excellent pieces of Ronde Cevenole. I know it’s cheating but I like using the GPS feature in PnG which isn’t available in GTL. I’ve been looking in GTL for the sound issue assuming the sounds would be the same in both sims since the files are the same. Maybe that's a bad assumption.

I’m using Windows 7.
GTR2man is offline   Reply With Quote
Unread 5 July 16, 09:51   #120
pistoncup
Uploader
 
pistoncup's Avatar
 
Join Date: Apr 2012
Location: Australia
Default

I'm not sure if this will work or not ? I think this will stretch the sound a bit further in your top speed.

If you drive cockpit you could try try increasing the max rpm in this section of the .aud file . Maybe try 9750.00 rpm

EngineRPMPowerInside=3
{
MinimumRPM=7030.00 // must overlap properly
MaximumRPM=9500.00 // must overlap properly
NaturalRPM=6000.00 // engine RPM at which sample was recorded
pistoncup is offline   Reply With Quote
Unread 13 July 16, 02:06   #121
GTR2man
Premium Member
 
Join Date: Nov 2006
Location: Dayton, OH, USA
Age: 77
Default

Pistoncup, thanks for the reply.

I finally found one of the cars with this issue. There are others but the one I just found is the 1953-1955 Corvette for GTL found at the trackaholics site by MG421982. I recently downloaded these classic Vettes. They use Cars\lotus wave sound files. I do use the cockpit view.

Here are the original lines for the inside power sounds.

// power inside
EngineRPMPowerInside=0
{
MinimumRPM=1.00 // above zero, but low enough to hear engine stall
MaximumRPM=1880.00 // must overlap properly
NaturalRPM=1150.00 // engine RPM at which sample was recorded
}

EngineRPMPowerInside=1
{
MinimumRPM=1260.00 // must overlap properly
MaximumRPM=3333.00 // must overlap properly
NaturalRPM=3000.00 // engine RPM at which sample was recorded
}

EngineRPMPowerInside=2
{
MinimumRPM=2607.00 // must overlap properly
MaximumRPM=4829.00 // must overlap properly
NaturalRPM=4000.00 // engine RPM at which sample was recorded
}

EngineRPMPowerInside=3
{
MinimumRPM=3868.00 // must overlap properly
MaximumRPM=6410.00 // must overlap properly
NaturalRPM=6000.00 // engine RPM at which sample was recorded
}

EngineRPMPowerInside=4
{
MinimumRPM=5449.00 // must overlap properly
MaximumRPM=9500.00 // must overlap properly
NaturalRPM=7000.00 // engine RPM at which sample was recorded
}

I changed the last MaximumRPM to 10000.00 and the dropped or paused sound still occurs. Driving the Daytona oval at constant rpm in high gear, I hear the drops beginning around 4000 rpm, then up to max about 5800. That might be a clue.

Any ideas from anyone?
GTR2man is offline   Reply With Quote
Unread 13 July 16, 05:39   #122
GTR233
Uploader
 
GTR233's Avatar
 
Join Date: Aug 2010
Default

If you want help then post the full aud file and not just a part of it ... Nevertheless it seems to be a bad wav file...
Anyway if you have issues with engine sound in a mod then the most easy fix is to copy aud file from anither car which you know is good... And try to keep the same kind of engine sound, I mean a bmw m3 sound on a corvette is not a good idea
GTR233 is offline   Reply With Quote
Unread 1 September 16, 08:26   #123
XtC24
 
Join Date: Jun 2015
Default

Hi,

I have the problem with TS 040 sound as described couple of posts above.

I think now that it could be the problem with the wav file - it is short - about 3 seconds. It could be that it goes from the start after 3 sec. ?

Regardless, I tried to make that file longer in couple of sound editors and I cannot merge two or 3 shorter parts to one so that there is no noise(pause?) in the connection point.

I tried to merge seamlessly but could not make it - tried fade out/fade in, stretching does not work, I even tried to manually match, connect sounds in biggest zoom, should be perfect, right?
And it stills makes big noise


here is the aud file btw:

//-----------------------
// ENGINE SOUNDS
//-----------------------

// ENGINE SOUNDS (INSIDE)

// inside coasting
VS_INSIDE_COAST_ENGINE_1=GRID\toyota_TS040\ts040_i nt_idle.wav
VS_INSIDE_COAST_ENGINE_2=GRID\toyota_TS040\ts040_o fflow.wav
VS_INSIDE_COAST_ENGINE_3=GRID\toyota_TS040\ts040_o fflow.wav
VS_INSIDE_COAST_ENGINE_4=GRID\toyota_TS040\ts040_o fflow.wav


// inside on-throttle
VS_INSIDE_POWER_ENGINE_1=GRID\toyota_TS040\ts040_i nt_idle.wav
VS_INSIDE_POWER_ENGINE_2=GRID\toyota_TS040\ts040_o fflow.wav
VS_INSIDE_POWER_ENGINE_3=GRID\toyota_TS040\ts040_o fflow.wav
VS_INSIDE_POWER_ENGINE_4=GRID\toyota_TS040\ts040_o nhigh.wav

VS_INSIDE_ENGINE_STARTER=GRID\toyota_TS040\int_sta rter.wav
VS_INSIDE_ENGINE_STARTING=GRID\toyota_TS040\int_st arting.wav

// ENGINE SOUNDS (OUTSIDE)


// BACKFIRE & SHIFT SOUNDS (INSIDE)

//VS_INSIDE_SHIFT_UP_1=GRID\toyota_TS040\int_shiftin g_1.wav
//VS_INSIDE_SHIFT_UP_2=GRID\toyota_TS040\int_shiftin g_2.wav
//VS_INSIDE_SHIFT_UP_3=GRID\toyota_TS040\int_shiftin g_3.wav
//VS_INSIDE_SHIFT_DOWN_1=GRID\toyota_TS040\int_shift ing_1.wav
//VS_INSIDE_SHIFT_DOWN_2=GRID\toyota_TS040\int_shift ing_2.wav
//VS_INSIDE_SHIFT_DOWN_3=GRID\toyota_TS040\int_shift ing_3.wav

VS_INSIDE_SHIFT_UP_1=null
VS_INSIDE_SHIFT_UP_2=null
VS_INSIDE_SHIFT_UP_3=null
VS_INSIDE_SHIFT_DOWN_1=null
VS_INSIDE_SHIFT_DOWN_2=null
VS_INSIDE_SHIFT_DOWN_3=null

VS_INSIDE_BACKFIRE_1=null
VS_INSIDE_BACKFIRE_2=null
VS_INSIDE_BACKFIRE_3=null

// BACKFIRE & SHIFT SOUNDS (OUTSIDE)


// ROAD SURFACE SOUNDS (INSIDE)

VS_INSIDE_ROADNOISE_DRY=GRID\toyota_TS040\road_rol l_int.wav
VS_INSIDE_ROADNOISE_WET=GRID\toyota_TS040\road_rol l_int_wet.wav
VS_INSIDE_ROADNOISE_RUMBLESTRIP=GRID\toyota_TS040\ rumble.wav
VS_INSIDE_ROADNOISE_GRASS=GRID\toyota_TS040\grass_ roll_int.wav
VS_INSIDE_ROADNOISE_DIRT=GRID\toyota_TS040\gravel_ roll_int.wav
VS_INSIDE_ROADNOISE_GRAVEL=GRID\toyota_TS040\grave l_roll_int.wav


// SKID SOUNDS (INSIDE)

VS_INSIDE_TIRE_SCRUB=GRID\toyota_TS040\road_scrub_ int.wav
VS_INSIDE_SKID_DRY=GRID\toyota_TS040\road_skid_int .wav
VS_INSIDE_SKID_WET=GRID\toyota_TS040\road_skid_int _wet.wav
VS_INSIDE_SKID_GRASS=GRID\toyota_TS040\grass_skid_ int.wav
VS_INSIDE_SKID_DIRT=GRID\toyota_TS040\gravel_skid_ int.wav
VS_INSIDE_SKID_GRAVEL=GRID\toyota_TS040\gravel_ski d_int.wav


// ROAD SURFACE SOUNDS (OUTSIDE)

VS_OUTSIDE_ROADNOISE_DRY=GRID\toyota_TS040\road_ro ll_ext.wav
VS_OUTSIDE_ROADNOISE_WET=GRID\toyota_TS040\road_ro ll_ext_wet.wav
VS_OUTSIDE_ROADNOISE_RUMBLESTRIP=GRID\toyota_TS040 \rumble_ext.wav
VS_OUTSIDE_ROADNOISE_GRASS=GRID\toyota_TS040\grass _roll_ext.wav
VS_OUTSIDE_ROADNOISE_DIRT=GRID\toyota_TS040\gravel _roll_ext.wav
VS_OUTSIDE_ROADNOISE_GRAVEL=GRID\toyota_TS040\grav el_roll_ext.wav

// SKID SOUNDS (OUTSIDE)

VS_OUTSIDE_TIRE_SCRUB=GRID\toyota_TS040\road_scrub _ext.wav
VS_OUTSIDE_SKID_DRY=GRID\toyota_TS040\road_skid_ex t.wav
VS_OUTSIDE_SKID_WET=GRID\toyota_TS040\road_skid_ex t_wet.wav
VS_OUTSIDE_SKID_GRASS=GRID\toyota_TS040\grass_skid _ext.wav
VS_OUTSIDE_SKID_DIRT=GRID\toyota_TS040\gravel_skid _ext.wav
VS_OUTSIDE_SKID_GRAVEL=GRID\toyota_TS040\gravel_sk id_ext.wav

// CONTACT SOUNDS (INSIDE)

VS_INSIDE_SCRAPING=GRID\toyota_TS040\scrape_int.wa v

VS_INSIDE_HIT_WALL_1=GRID\toyota_TS040\impact_wall _tap.wav
VS_INSIDE_HIT_WALL_2=GRID\toyota_TS040\impact_wall _verylight.wav
VS_INSIDE_HIT_WALL_3=GRID\toyota_TS040\impact_wall _light.wav
VS_INSIDE_HIT_WALL_4=GRID\toyota_TS040\impact_wall _medium.wav
VS_INSIDE_HIT_WALL_5=GRID\toyota_TS040\impact_wall _heavy.wav

VS_INSIDE_HIT_OTHERCAR_1=GRID\toyota_TS040\impact_ car_tap.wav
VS_INSIDE_HIT_OTHERCAR_2=GRID\toyota_TS040\impact_ car_verylight.wav
VS_INSIDE_HIT_OTHERCAR_3=GRID\toyota_TS040\impact_ car_light.wav
VS_INSIDE_HIT_OTHERCAR_4=GRID\toyota_TS040\impact_ car_medium.wav
VS_INSIDE_HIT_OTHERCAR_5=GRID\toyota_TS040\impact_ car_heavy.wav

VS_INSIDE_HIT_CONE=GRID\toyota_TS040\impact_cone.w av

// CONTACT SOUNDS (OUTSIDE)

VS_OUTSIDE_SCRAPING=GRID\toyota_TS040\scrape_ext.w av

VS_OUTSIDE_HIT_WALL_1=GRID\toyota_TS040\impactex_w all_tap.wav
VS_OUTSIDE_HIT_WALL_2=GRID\toyota_TS040\impactex_w all_verylight.wav
VS_OUTSIDE_HIT_WALL_3=GRID\toyota_TS040\impactex_w all_light.wav
VS_OUTSIDE_HIT_WALL_4=GRID\toyota_TS040\impactex_w all_medium.wav
VS_OUTSIDE_HIT_WALL_5=GRID\toyota_TS040\impactex_w all_heavy.wav

VS_OUTSIDE_HIT_OTHERCAR_1=GRID\toyota_TS040\impact ex_car_tap.wav
VS_OUTSIDE_HIT_OTHERCAR_2=GRID\toyota_TS040\impact ex_car_verylight.wav
VS_OUTSIDE_HIT_OTHERCAR_3=GRID\toyota_TS040\impact ex_car_light.wav
VS_OUTSIDE_HIT_OTHERCAR_4=GRID\toyota_TS040\impact ex_car_medium.wav
VS_OUTSIDE_HIT_OTHERCAR_5=GRID\toyota_TS040\impact ex_car_heavy.wav

VS_OUTSIDE_HIT_CONE=GRID\toyota_TS040\impactex_con e.wav


// AMBIENT SOUNDS (INSIDE)

VS_INSIDE_SPEED_LIMITER_TOGGLE=GRID\toyota_TS040\l imitertoggle_evo_int.wav
VS_INSIDE_WIND_NOISE=GRID\toyota_TS040\windrush_in .wav
VS_INSIDE_TRACTION_CONTROL=GRID\toyota_TS040\revli miter_evo_int.wav
VS_INSIDE_RAIN_NOISE=GRID\toyota_TS040\rain.wav
VS_INSIDE_ON_FIRE=GRID\toyota_TS040\on_fire_int.wa v


// AMBIENT SOUNDS (OUTSIDE)

VS_OUTSIDE_SPEED_LIMITER_TOGGLE=GRID\toyota_TS040\ limitertoggle_evo_ext.wav
VS_OUTSIDE_WIND_NOISE=GRID\toyota_TS040\windrush_e x.wav
VS_OUTSIDE_TRACTION_CONTROL=GRID\toyota_TS040\revl imiter_evo_ext.wav
VS_OUTSIDE_RAIN_NOISE=GRID\toyota_TS040\rain.wav
VS_OUTSIDE_ON_FIRE=GRID\toyota_TS040\on_fire_ext.w av

// ATTENUTATION
EngineRange=80.0
EngineShape=0.90
EngineAmbient=2.00

ShiftRange=80.0
ShiftShape=0.90
ShiftAmbient=2.00

OtherRange=80.0
OtherShape=0.70
OtherAmbient=0.70


// ENGINE VOLUME MIX

playerEngineVolumeMinimum=0.5
playerEngineVolumeThrottleFraction=0.5
playerEngineVolumeRevFraction=0.0

non-playerEngineVolumeMinimum=0.3
non-playerEngineVolumeThrottleFraction=0.3
non-playerEngineVolumeRevFraction=0.4


// ENGINE THROTTLE-POSITION MIX
EngineLoadBlendInside=(0.05,0.9) // power sound starts to blend in at 10% throttle, coast sound blends out at 70%
EngineLoadBlendOutside=(0.05,0.9) // power sound starts to blend in at 10% throttle, coast sound blends out at 70%


// ENGINE THROTTLE-POSITION MIX
EngineLoadBlendInside=(0.3,0.7) // power sound starts to blend in at 30% throttle, coast sound blends out at 70%
EngineLoadBlendOutside=(0.3,0.7) // power sound starts to blend in at 30% throttle, coast sound blends out at 70%


// ENGINE REV-SAMPLE MIX
// RPMs need to overlap properly from one sample to the next (maximum of two playing at once).
// The first minimum RPM should be above zero but low enough to hear an engine stall.

// coast inside
EngineRPMCoastInside=0
{
MinimumRPM=1.00
MaximumRPM=2043.00
NaturalRPM=1465.60
}
EngineRPMCoastInside=1
{
MinimumRPM=1680.00
MaximumRPM=5239.00
NaturalRPM=3798.40
}
EngineRPMCoastInside=2
{
MinimumRPM=3234.00
MaximumRPM=5985.00
NaturalRPM=6396.80
}
EngineRPMCoastInside=3
{
MinimumRPM=4530.00
MaximumRPM=9000.00
NaturalRPM=9079.41
}
EngineRPMCoastInside=4
{
MinimumRPM=7030.00
MaximumRPM=15000.00
NaturalRPM=12396.80
}


// power inside
EngineRPMPowerInside=0
{
MinimumRPM=1.00
MaximumRPM=2043.00
NaturalRPM=1465.60
}
EngineRPMPowerInside=1
{
MinimumRPM=1680.00
MaximumRPM=5239.00
NaturalRPM=3798.40
}

EngineRPMPowerInside=2
{
MinimumRPM=3234.00
MaximumRPM=5985.00
NaturalRPM=6396.80
}

EngineRPMPowerInside=3
{
MinimumRPM=4530.00
MaximumRPM=9000.00
NaturalRPM=10097.44
}

EngineRPMPowerInside=4
{
MinimumRPM=7030.00
MaximumRPM=15000.00
NaturalRPM=12396.80
}

// coast outside
EngineRPMCoastOutside=0
{
MinimumRPM=1.00
MaximumRPM=2043.00
NaturalRPM=1465.60
}

EngineRPMCoastOutside=1
{
MinimumRPM=1680.00
MaximumRPM=5239.00
NaturalRPM=3678.24
}

EngineRPMCoastOutside=2
{
MinimumRPM=3234.00
MaximumRPM=7985.00
NaturalRPM=6536.48
}

EngineRPMCoastOutside=3
{
MinimumRPM=5530.00
MaximumRPM=10000.00
NaturalRPM=6536.48
}

EngineRPMCoastOutside=4
{
MinimumRPM=8230.00
MaximumRPM=15000.00
NaturalRPM=12636.48
}

/
// TRANNY-SAMPLE MIX /////////////////////////////////////////////////////////////////////

VS_INSIDE_COAST_TRANNY_1=EEC_LMP\Toyota\tranny_coa st_low.wav
VS_INSIDE_COAST_TRANNY_2=EEC_LMP\Toyota\tranny_coa st_high.wav
VS_INSIDE_POWER_TRANNY_1=EEC_LMP\Toyota\trany_powe r_low.wav
VS_INSIDE_POWER_TRANNY_2=EEC_LMP\Toyota\tranny_coa st_high.wav

VS_OUTSIDE_COAST_TRANNY_1=EEC_LMP\Toyota\ext_trany _coast_low.wav
//VS_OUTSIDE_COAST_TRANNY_2=null
VS_OUTSIDE_POWER_TRANNY_1=EEC_LMP\Toyota\ext_trany _power_low.wav
//VS_OUTSIDE_POWER_TRANNY_2=null

TrannyInitialRampRPM=1500.0 // ramp volume up to this driveshaft RPM because low pitches sound bad

TrannyCoastBlendRPMInside=(2000.0, 7500.0) // blend range using driveshaft RPM
TrannyCoast1RPMTorqueInside=(1725, 1200.0) // natural RPM at which sample was recorded, transmission torque (in Nm) for maximum volume
TrannyCoast2RPMTorqueInside=(8643, 500.0)

TrannyPowerBlendRPMInside=(4000.0, 7500.0)
TrannyPower1RPMTorqueInside=(1025, 200.0)
TrannyPower2RPMTorqueInside=(9398, 600.0)
XtC24 is offline   Reply With Quote
Unread 1 September 16, 12:08   #124
DooGal
 
DooGal's Avatar
 
Join Date: Dec 2005
Default

Just a humble suggestion that may be of use -
http://www.siimannuk.com/enginesoundeditor-for-rfactor/
Don't save with it though, use it to get the settings you need then edit the aud/sfx file yourself.
DooGal is offline   Reply With Quote
Unread 1 September 16, 21:47   #125
burps
 
Join Date: Jun 2008
Default

http://www.nogripracing.com/forum/sh...ad.php?t=21694

Look at Part 2. This should be the solution to your problem. It's worth reading the whole thread from the beginning.

Good Luck
burps is offline   Reply With Quote
Unread 3 September 16, 00:51   #126
pistoncup
Uploader
 
pistoncup's Avatar
 
Join Date: Apr 2012
Location: Australia
Default

TS 040 should be fully updated by now , Plenty of GTR2 Lemans freaks that would of fixed the car ages ago.
pistoncup is offline   Reply With Quote
Unread 3 September 16, 08:32   #127
XtC24
 
Join Date: Jun 2015
Default

Thank you guys.
I read the whole thread first, of course. Tried a lot of things in editors but I am trying on and will not give up yet .

For now, I copied big chunk of the sound inside itself and the pause (tek,tek) is gone but the sound is far rom natural yet.
Still, I am not 100% sure that it is the problem of the .wav.

The Ts 040 sound is not solved afaik, I saw the car on youtube and it never used this sweet realistic sound inside.

There are not so much fans of LM and this car appparently.
XtC24 is offline   Reply With Quote
Unread 3 September 16, 12:56   #128
pistoncup
Uploader
 
pistoncup's Avatar
 
Join Date: Apr 2012
Location: Australia
Default

What about using the TSO30 mod sounds ? just rename the .aud file to suit the TSO40
This mod sounds all right. In fact sounds are pretty good.
https://www.youtube.com/watch?v=terY_F682tQ

Last edited by pistoncup; 3 September 16 at 13:33.
pistoncup is offline   Reply With Quote
Unread 10 September 16, 21:25   #129
XtC24
 
Join Date: Jun 2015
Default

I have tried already couple of other sounds including the one you mentioned.

I am meanwhile a little further, I managed to equalize the pitch (as far as I could) for the whole wav, because it was recorded going up.
So the main problem was that in the game it was just playing the sample (2,7 seconds) on and on in a loop,
And the problem occured only on 6 and 7 gear cause the car goes naturally more than 3 seconds on 7 gear, especially at La Sarthe

So now I have it on the same pitch and just need to connect two or more identical samples together seamlessly. I will try the fade in and out and inversion again.
XtC24 is offline   Reply With Quote
Unread 12 September 16, 08:08   #130
pistoncup
Uploader
 
pistoncup's Avatar
 
Join Date: Apr 2012
Location: Australia
Default

I was just thinking if you are having troubles joining sound files you could try a demo version of a DJ mixing program like Virtual DJ or similar. Some are better than others.
It's been a long time since I have used one so they should be even better now days. You can record obviously but also seamlessly loop, cut, join, stretch, change pitch and speed, all sorts of stuff.

with the 2 DJ decks you can play two sounds at once or a few seconds apart and record them together as one sound file. Then load that recorded sound file up and endlessly keep going if you want.

Last edited by pistoncup; 12 September 16 at 08:33.
pistoncup is offline   Reply With Quote
Unread 14 September 16, 20:37   #131
XtC24
 
Join Date: Jun 2015
Default

Thanks for the hint, I will check it out!
XtC24 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 12:43.
Home - Top

Powered by vBulletin® - Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

www.nogripracing.com 2003 - 2018